Jump to content
This site uses cookies! Learn More

This site uses cookies!

You can find a list of those cookies here: mysite.com/cookies

By continuing to use this site, you agree to allow us to store cookies on your computer. :)

Steve86

Compressor not getting up to pressure

Recommended Posts

Hi Folks

Anybody got any ideas why my Iwata Sprint Jet compressor is not getting up to pressure, the motor is running but at best is only reaching 4/5psi. Is it repairable or time to buy a new one?

 

Many thanks for any help or advice.

Steve

Share this post


Link to post
Share on other sites

It all depends on the problem,  does it sound right ?

 

Are all the hose connections tight/any leaks ?

 

Is the regulator  working properly ?

Does it bleed air out when you open it up ?

 

Have you tried connecting a hose directly to the output from the compressor, bypassing  the external moisture trap regulator.

 

Paul

Share this post


Link to post
Share on other sites

Hi Paul

Thanks for the ideas, yes it does sound OK and yes the bleed valve at the bottom of the water trap works OK. As for the other suggestions I will have to work through them went I get a few minutes.

 

Steve

Share this post


Link to post
Share on other sites

I had this problem, but not on the same compressor. There was a tiny hole in the tank, so air was escaping and it never got up to full pressure. I cleaned the area and welded the hole up. Solved the problem..

Share this post


Link to post
Share on other sites

Hi Steve thanks for that, but mine has not got a tank fitted.

 

But it's worth knowing for the future.

Steve

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...