Jump to content
This site uses cookies! Learn More

This site uses cookies!

You can find a list of those cookies here: mysite.com/cookies

By continuing to use this site, you agree to allow us to store cookies on your computer. :)

onurkafadar

1/35 T34/76 Winter Camo|Tamiya

Recommended Posts

Hi there

 

I just took delivery of this kit off EBay for a tenner. So will be using this cracking example as inspiration.

relly nice job overall. I really like the distinction between turret and main hull. Mud and winter camo is perfect, really nice touch👌

 

Simon

Edited by Redcoat2966

Share this post


Link to post
Share on other sites

Fabulous weathering techniques!  I like the contrast between the turret and hull it makes the model very dynamic.  I see you put the trusty Tamiya painting stand to good use.  Is that Mr Cement that you are using ?  Do you prefer that over the Tamiya ultra thin quick drying ?

Share this post


Link to post
Share on other sites
On 16.02.2018 at 3:20 PM, combat said:

Fabulous weathering techniques!  I like the contrast between the turret and hull it makes the model very dynamic.  I see you put the trusty Tamiya painting stand to good use.  Is that Mr Cement that you are using ?  Do you prefer that over the Tamiya ultra thin quick drying ?

Mr.Cement is better than tamiya green head

Share this post


Link to post
Share on other sites

Hi chaps, see you debating thin cements.......

 

If you want a thin cement, I would recommend this.

 

SCIGRIP 4SC - - It's a tenner a can for nearly 500ml as compared to Tamiya and similar at around £4 for 40ml. To get the same amount as SCIGRIP in Tamiya would cost over £45.

 

I just decant what I need into a smaller bottle. There are different types available, but I find this one is one I like for a fast, quick dry. 

 

SNgGnE9.jpg

 

Regards

 

Simon.

Share this post


Link to post
Share on other sites

is it me or are the  images not working on this??

 

Share this post


Link to post
Share on other sites
23 minutes ago, robw_uk said:

is it me or are the  images not working on this??

 

Same here!

 

Rick.

Share this post


Link to post
Share on other sites
11 minutes ago, onurkafadar said:

t88.JPG

That works.

1 minute ago, onurkafadar said:

2Jpg8L.jpg

BLjMDV.jpg

Z9lDkg.jpg

This doesn't!

Share this post


Link to post
Share on other sites

The same on Firefox as well as Chrome.

 

Rick.

Share this post


Link to post
Share on other sites
Just now, onurkafadar said:

oOJg3Q.jpg

Nope

Share this post


Link to post
Share on other sites
1 minute ago, onurkafadar said:

Z9lDkg.jpg

Nope.

Off to work.

Good luck!

Rick.

Share this post


Link to post
Share on other sites
Posted (edited)

Don't know how you are posting these .jpgs but I can't see anything with Windows10.

 

Maybe try Imgur as it's free. 

 

Lloyd

Edited by BlackMax12

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×