Jump to content
This site uses cookies! Learn More

This site uses cookies!

You can find a list of those cookies here: mysite.com/cookies

By continuing to use this site, you agree to allow us to store cookies on your computer. :)

Sign in to follow this  
TheVoidDragon

Problems with Citadel Imperial Primer

Recommended Posts

A few years ago i bought some Citadel Imperial Primer but never really got around to trying to properly use it until recently, and i'm having problems with it. It's really thin, watery and full of bubbles, can even hear them crackling when the brush is put in. The first time i tried undercoating the model i'm working on, one side of it ended up all just pooling together, while the other side of the model at least had the paint stick but ended up full of brush marks and general lack of good coverage and comes off easily. Tried washing the model in warm soapy water beforehand (twice now) to see if that helps but there's still basically no consistency to it with it seeming to do pretty much nothing noticeable when i try to paint it on as an undercoat. It's a Lindberg ME-163 Komet i'm trying it on, so i don't know if the Imperial Primer is the problem, if I'm just doing something wrong, or it's something to do with the kit itself (which is pretty poor quality i think). Looking around I've not really found anything that helps with the problem, is anyone able to help at all?

Share this post


Link to post
Share on other sites

There are several reviews on Imperial Primer that have found this problem: thin consistency, poor coverage and bubbles. I believe the primer itself is the issue. For an undercoat, I suggest Halfords Grey primer spray. Hope this helps.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×