Jump to content
This site uses cookies! Learn More

This site uses cookies!

You can find a list of those cookies here: mysite.com/cookies

By continuing to use this site, you agree to allow us to store cookies on your computer. :)

Sign in to follow this  
James G

Problems with microscale decal film

Recommended Posts

Hi All,

 

I've had some problems using Microscale decal film on inkjet printed decals (on Experts Choice decal paper)...gave the decals a coat of decal film about 20 mins after printing and they have cracked up. I applied them using Microset and some of the colour has bled out. I've never had such problems before...the possibilities for what could have gone wrong are as follows:

1) I did not leave enough time between the printing and the first coat of decal film;

2) The first coat was too heavy; or

3) The decal film has 'gone off' (does it require shaking beforehand?)

 

Any tips?

 

Thanks,

 

James

Share this post


Link to post
Share on other sites

I've always left the ink to dry overnight before coating with Liquid Decal Film. I also apply two coats, just to be sure.

 I have found that the colour can bleed if you soak the decals for too long. Best to get the, in place as quick as possible.

Share this post


Link to post
Share on other sites

Hi James,

 

I found that by using the Ink Dry powder to absorb extra ink immediately after printing, and the clear, flexible topcoat sealer (spray can), my Epson-printed decals came out perfectly, from Papilion.com.

 

Ed

 

(I have no conections with...yada...yada...yada)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×